Don’t leave OutLinker Code on your Clipboard after Installation

One handy feature of MindReader is its ability to set the current contents of the clipboard as a task’s hyperlink or note if you include a keyword (isnote, see note, islink, see link). As currently configured it always grabs the contents of the clipboard and puts it in the queue file because it can’t know ahead of time if one of these keywords is present.

The first step in OutLinker Installation is to copy/paste the macro code into the Microsoft Outlook macro editor. As it turns out, something about the size or specific content of the current macro text confuses GyroQ if it is captured from the clipboard while using the “q” or “fq” command. This leads GyroQ to choke on the clipboard contents. This has impacted several OutLinker users in last few days (including me). The fix is to clear your queue and then make sure you clear your clipboard by clicking on the clipboard icon on the GyroQ dialog box or replace the context with something smaller.

I’d like to avoid the problem above in general. There are two options I can think of to address it. One is to create a separate tag (cq, lq, nq?) to use on occasions when you plan to capture the clipboard contents as a note or link. This option could either use the clipboard as is or prompt you to paste in content to a dialog box directly

The 2nd is to change q/fq to require you to invoke GyroQ with the “textgrab” option (Control-ShiftG). This feature wasn’t available when MindReader first launched.

Comment below with your preferences.


  1. Mal said,

    January 24, 2008 @ 11:40 pm

    I suggest using Control-ShiftG. This is already built-in to GyroQ for a start bt primarily i would like to keep tags to a minimum (so that I can remember them) and avoid having different tags for variants of other tags.

  2. ActivityOwner said,

    January 26, 2008 @ 12:46 am

    At the time the Control-Shift-G “textgrab” functionality came out, I didn’t want to cut over while most users where on the old version, so I set up “q” and “fq” to work either way.

    I just changed mindreaderopen so that fq can use the textgrab alone. This has an added benefit of eliminating the need for link and note keywords! If you grab a link it becomes a link and other stuff becomes notes.

  3. ActivityOwner said,

    January 26, 2008 @ 12:52 am

    Note that to get the above to work, you need to use the m tag to “setoption:usetextgrab:1”

    This is now the default behavior. If you set usetextgrab:0, then it will work the old way.


  4. MindReader Update: Capture notes and links without using keywords » ActivityOwner.Com said,

    January 27, 2008 @ 11:51 am

    […] Having large amounts of clipboard text go into queue file could cause GyroQ problems […]

  5. nigel said,

    January 29, 2008 @ 10:48 am

    Having an issue with the latest and greatest Outlinker (29-Jan-2008). I have not caught the issue in the code yet, but sometimes when I run Outlinker it does not complete. The Outlinker macro button in Outlook stays highlighted and my mouse stays as a hourglass until I forcibly close the outlook application.

    When it does hang, I never get that final box giving me the numbers of all my actions. I have tried to replicate with one or two emails with no luck. Is any one else having this issue?

  6. ActivityOwner said,

    January 29, 2008 @ 10:53 pm

    Give the “Outlinker 29-Jan-2008 – 3” version a try. This sounds like a recent bug that was just swatted yesterday. I had the dates wrong so the original “29” was actually an early 28.

  7. Marco van Laerhoven said,

    February 15, 2008 @ 1:40 pm

    Noticed a slight issue with messages that are over 32K long (unfortunately, this happens). The function ValidXmlChars is using an int to loop trough the string, and will fail when the counter becomes too large: overflow. The message is then moved to the archive, but there is no link in the map.
    Maybe the number of characters to be included in the textnote needs to be restricted to 32K

  8. ActivityOwner said,

    February 15, 2008 @ 7:16 pm

    Hi Marco — I fixed that issue in on 9Feb. You can download latest version of the wiki.

    I don’t think the validxml function was actually necessary in the first place. It turned out the map crashing issue I was trying to fix was related to bad links being created in an older version.

RSS feed for comments on this post · TrackBack URI

Leave a Comment

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 2.5 License.